DJI Permission for Aircraft Warning

Do you see user does not have permission for this aircraft, takeoff prohibited by app (and main screen shows red flag in top right corner)?

Cause:

  1. The pilot is logged into the wrong account.
    1. Your drone is linked to the account it was activated to so you have to be logged into that account to fly unless the aircraft has been transferred.
  2. If right after activation, the account has not refreshed to reflect addition.
  3. The drone has been transferred to a different user or has not been transferred to you.
    1. If you bought your drone that has already been activated from an individual, that drone needs to be transferred to your DJI account.
  4. You did not select the correct team to fly the drone.
    1. This is only if your company has multiple teams.
  5. If it has a new Aerial Electronics Modules
    1. This is the main flight controller for the aircraft and will bar it from flight if the serial number has not been swapped in the DJI system (which must be done by a dealer).

Diagnosing:

  1. Check the profile screen, by clicking the person icon on the begin screen, and make sure you are logged into the correct team and account.
  2. Log into the DJI AGMS app on your computer and make sure the drone appears in your registered devices.
  3. Make sure the drone is associated with the correct teams, most people will just use the default team.

Solutions:

  1. If directly after activation, log out of the account and log back in on the controller to refresh the devices associated with the account.
  2. Contact the individual that you purchased the drone from and make sure the drone has been transferred to your DJI account.
  3. If the Aerial Electronics Module has been replaced, contact the company that you bought it from to make sure the serial numbers have been swapped in DJI’s system.
    1. You will have to click activate on the device information screen and log out and back into your account on the RC after activation.
  4. Make sure you are logged into the correct account; any typos will cause this error.